// Neulich im Baumarkt...

Vor kurzem konnte ich in einem gewissen Baumarkt am Uhu „Stand“ folgende Fehlermeldung auf einer Embedded-Maschine mit Touchscreen, die eigentlich, wie ich bei meinem Besuch zwei Wochen später herausfinden konnte, zur Auswahl des richtigen Klebestoffes da ist (und nicht zum Anzeigen von lokalen Apache 404ern), zu Gesicht bekommen:

Wie aus den Bilder (leider relativ schlechte Qualität) unschwer zu erkennen ist läuft diese Maschine mit Ubuntu – ich hätte eher auf ein Windows CE oder ähnliches getippt. Auch scheint der Apache tatsächlich auf der kleinen Box laufen, was an dem Footer „Apache … Server at localhost Port 80“ erkennbar ist. Die auf jenem System verwendete Software ist aber gnadenlos veraltet (Apache 2.0.55 und PHP 5.1.2). Zum Vergleich die Versionen auf einem Lucid Server:

ich@server:~$ dpkg -l | grep apache
ii  apache2                                   2.2.14-5ubuntu8.7
ich@server:~$ dpkg -l | grep php5
ii  php5                                      5.3.2-1ubuntu4.11
Hello World!

This is the personal website of Christoph Winkler aka chrisge.
Here you will find a sort of blog and some information about me and my projectshave fun!

Recent Comments
Latest Tweets

Follow me on Twitter...

QR-Code: aktuelle Seiten-URL
Falls nicht anders bezeichnet, ist der Inhalt dieses Wikis unter der folgenden Lizenz veröffentlicht: CC Attribution-Noncommercial-Share Alike 3.0 Unported